debian/rules
author insilmaril
Wed, 25 Jan 2006 09:05:57 +0000
changeset 195 98f260cfb1fe
parent 156 32dec8762b2d
permissions -rw-r--r--
Added missing file.h file.cpp
     1 #!/usr/bin/make -f
     2 # -*- makefile -*-
     3 # Sample debian/rules that uses debhelper.
     4 # This file was originally written by Joey Hess and Craig Small.
     5 # As a special exception, when this file is copied by dh-make into a
     6 # dh-make output file, you may use that output file without restriction.
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
     8 
     9 # Uncomment this to turn on verbose mode.
    10 #export DH_VERBOSE=1
    11 
    12 
    13 
    14 
    15 CFLAGS = -Wall -g
    16 
    17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
    18 	CFLAGS += -O0
    19 else
    20 	CFLAGS += -O2
    21 endif
    22 
    23 configure: configure-stamp
    24 configure-stamp:
    25 	dh_testdir
    26 	# Add here commands to configure the package.
    27 	qmake
    28 	dpatch apply-all
    29 	make
    30 	touch configure-stamp
    31 
    32 
    33 build: build-stamp
    34 
    35 build-stamp: configure-stamp 
    36 	dh_testdir
    37 
    38 	# Add here commands to compile the package.
    39 	$(MAKE)
    40 	#docbook-to-man debian/vym.sgml > vym.1
    41 
    42 	touch build-stamp
    43 
    44 clean:
    45 	dh_testdir
    46 	dh_testroot
    47 	rm -f build-stamp configure-stamp
    48 	rm -rf debian/patched
    49 	rm -rf vym
    50 	dpatch deapply-all
    51 	# Add here commands to clean up after the build process.
    52 	-$(MAKE) clean
    53 
    54 	dh_clean 
    55 
    56 install: build
    57 	dh_testdir
    58 	dh_testroot
    59 	dh_clean -k 
    60 	dh_installdirs
    61 	install -m 644 vym.desktop debian/vym/usr/share/applications/vym.desktop
    62 	# Add here commands to install the package into debian/vym.
    63 	$(MAKE) install DESTDIR=$(CURDIR)/debian/vym
    64 
    65 
    66 # Build architecture-independent files here.
    67 binary-indep: build install
    68 # We have nothing to do by default.
    69 
    70 # Build architecture-dependent files here.
    71 binary-arch: build install
    72 	dh_testdir
    73 	dh_testroot
    74 	dh_installchangelogs 
    75 	dh_installdocs
    76 	dh_installman
    77 	dh_installmenu
    78 	dh_link
    79 	dh_strip
    80 	dh_compress
    81 	dh_fixperms
    82 	dh_installdeb
    83 	dh_shlibdeps
    84 	dh_gencontrol
    85 	dh_md5sums
    86 	dh_builddeb
    87 
    88 binary: binary-indep binary-arch
    89 .PHONY: build clean binary-indep binary-arch binary install configure