debian/patches/10-debianlike.dpatch
author insilmaril
Fri, 19 Aug 2005 07:42:31 +0000
changeset 156 32dec8762b2d
permissions -rw-r--r--
added license in new aboutwindow and debian subdir by Steffen Joeris
     1 #!/bin/sh -e
     2 ## 10-debianlike.dpatch by Steffen Joeris <steffen.joeris@skolelinux.de>
     3 ##
     4 ## All lines beginning with `## DP:' are a description of the patch.
     5 ## DP: Here we make vym debianlike :=)
     6 
     7 if [ $# -lt 1 ]; then
     8 echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
     9 exit 1
    10 fi
    11 
    12 [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
    13 patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
    14 
    15 case "$1" in
    16       -patch) patch $patch_opts -p1 < $0;;
    17       -unpatch) patch $patch_opts -p1 -R < $0;;
    18       *)
    19       echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
    20       exit 1;;
    21 esac
    22 
    23 exit 0
    24 
    25 @DPATCH@
    26 --- Makefile.org	2005-08-05 17:37:51.546689964 +0200
    27 +++ vym-1.7.0/Makefile	2005-08-05 17:34:24.950701764 +0200
    28 @@ -172,7 +172,8 @@
    29  		moc_editxlinkdialog.o
    30  DIST	   = vym.pro
    31  QMAKE_TARGET = vym
    32 -DESTDIR  = 
    33 +DESTDIR  = debian/vym
    34 +INSTALL_ROOT= $(DESTDIR)
    35  TARGET   = vym
    36  
    37  first: all
    38 @@ -822,13 +823,13 @@
    39  
    40  
    41  install_doc: all 
    42 -	@$(CHK_DIR_EXISTS) "$(INSTALL_ROOT)/usr/share/doc/packages/vym/" || $(MKDIR) "$(INSTALL_ROOT)/usr/share/doc/packages/vym/"
    43 -	-$(INSTALL_FILE) "doc/vym.pdf" "$(INSTALL_ROOT)/usr/share/doc/packages/vym/"
    44 +	@$(CHK_DIR_EXISTS) "$(INSTALL_ROOT)/usr/share/doc/vym/" || $(MKDIR) "$(INSTALL_ROOT)/usr/share/doc/vym/"
    45 +	-$(INSTALL_FILE) "doc/vym.pdf" "$(INSTALL_ROOT)/usr/share/doc/vym/"
    46  
    47  
    48  uninstall_doc: 
    49 -	-$(DEL_FILE) -r "$(INSTALL_ROOT)/usr/share/doc/packages/vym/vym.pdf"
    50 -	-$(DEL_DIR) "$(INSTALL_ROOT)/usr/share/doc/packages/vym/"
    51 +	-$(DEL_FILE) -r "$(INSTALL_ROOT)/usr/share/doc/vym/vym.pdf"
    52 +	-$(DEL_DIR) "$(INSTALL_ROOT)/usr/share/doc/vym/"
    53  
    54  
    55  install_demo: all