insilmaril@156: #!/usr/bin/make -f
insilmaril@156: # -*- makefile -*-
insilmaril@156: # Sample debian/rules that uses debhelper.
insilmaril@156: # This file was originally written by Joey Hess and Craig Small.
insilmaril@156: # As a special exception, when this file is copied by dh-make into a
insilmaril@156: # dh-make output file, you may use that output file without restriction.
insilmaril@156: # This special exception was added by Craig Small in version 0.37 of dh-make.
insilmaril@156: 
insilmaril@156: # Uncomment this to turn on verbose mode.
insilmaril@156: #export DH_VERBOSE=1
insilmaril@156: 
insilmaril@156: 
insilmaril@156: 
insilmaril@156: 
insilmaril@156: CFLAGS = -Wall -g
insilmaril@156: 
insilmaril@156: ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
insilmaril@156: 	CFLAGS += -O0
insilmaril@156: else
insilmaril@156: 	CFLAGS += -O2
insilmaril@156: endif
insilmaril@156: 
insilmaril@156: configure: configure-stamp
insilmaril@156: configure-stamp:
insilmaril@156: 	dh_testdir
insilmaril@156: 	# Add here commands to configure the package.
insilmaril@156: 	qmake
insilmaril@156: 	dpatch apply-all
insilmaril@156: 	make
insilmaril@156: 	touch configure-stamp
insilmaril@156: 
insilmaril@156: 
insilmaril@156: build: build-stamp
insilmaril@156: 
insilmaril@156: build-stamp: configure-stamp 
insilmaril@156: 	dh_testdir
insilmaril@156: 
insilmaril@156: 	# Add here commands to compile the package.
insilmaril@156: 	$(MAKE)
insilmaril@156: 	#docbook-to-man debian/vym.sgml > vym.1
insilmaril@156: 
insilmaril@156: 	touch build-stamp
insilmaril@156: 
insilmaril@156: clean:
insilmaril@156: 	dh_testdir
insilmaril@156: 	dh_testroot
insilmaril@156: 	rm -f build-stamp configure-stamp
insilmaril@156: 	rm -rf debian/patched
insilmaril@156: 	rm -rf vym
insilmaril@156: 	dpatch deapply-all
insilmaril@156: 	# Add here commands to clean up after the build process.
insilmaril@156: 	-$(MAKE) clean
insilmaril@156: 
insilmaril@156: 	dh_clean 
insilmaril@156: 
insilmaril@156: install: build
insilmaril@156: 	dh_testdir
insilmaril@156: 	dh_testroot
insilmaril@156: 	dh_clean -k 
insilmaril@156: 	dh_installdirs
insilmaril@156: 	install -m 644 vym.desktop debian/vym/usr/share/applications/vym.desktop
insilmaril@156: 	# Add here commands to install the package into debian/vym.
insilmaril@156: 	$(MAKE) install DESTDIR=$(CURDIR)/debian/vym
insilmaril@156: 
insilmaril@156: 
insilmaril@156: # Build architecture-independent files here.
insilmaril@156: binary-indep: build install
insilmaril@156: # We have nothing to do by default.
insilmaril@156: 
insilmaril@156: # Build architecture-dependent files here.
insilmaril@156: binary-arch: build install
insilmaril@156: 	dh_testdir
insilmaril@156: 	dh_testroot
insilmaril@156: 	dh_installchangelogs 
insilmaril@156: 	dh_installdocs
insilmaril@156: 	dh_installman
insilmaril@156: 	dh_installmenu
insilmaril@156: 	dh_link
insilmaril@156: 	dh_strip
insilmaril@156: 	dh_compress
insilmaril@156: 	dh_fixperms
insilmaril@156: 	dh_installdeb
insilmaril@156: 	dh_shlibdeps
insilmaril@156: 	dh_gencontrol
insilmaril@156: 	dh_md5sums
insilmaril@156: 	dh_builddeb
insilmaril@156: 
insilmaril@156: binary: binary-indep binary-arch
insilmaril@156: .PHONY: build clean binary-indep binary-arch binary install configure